Unsuccessful Tunnel


Hello, using the latest build works fine at home, was so excited about this to share at work. Soon as I tried to login at work. Not working because of proxy? I get this:


2019-01-29T14:52:50 - [INFO][turtl_core::dispatch] dispatch(7): app:api:set-endpoint
2019-01-29T14:52:50 - [INFO][turtl_core::dispatch] dispatch(8): app:api:set-old-endpoint
2019-01-29T14:52:50 - [INFO][turtl_core::dispatch] dispatch(9): user:login
2019-01-29T14:52:50 - [INFO][turtl_core::models::user] user::generate_auth() – generating v0 auth
2019-01-29T14:52:50 - [DEBUG][turtl_core::api] api::req() – begin: POST /auth
2019-01-29T14:52:50 - [DEBUG][turtl_core::api] api::call() – req: using proxy: xxx.proxy.xxx.org:8080
2019-01-29T14:52:50 - [DEBUG][turtl_core::api] api::call() – req: POST https://apiv3.turtlapp.com/auth
2019-01-29T14:52:50 - [DEBUG][turtl_core::api] api::call() – call error: {“err”:{“message”:“https://apiv3.turtlapp.com/auth: an error occurred trying to connect: unsuccessful tunnel”,“type”:“generic”},“file”:“src\api.rs”,“line”:138,“wrapped”:true}
2019-01-29T14:53:29 - [INFO][turtl_core::dispatch] dispatch(10): app:get-log


These proxy errors can be really hard to debug if I’m not able to access the proxy. Is it public? If not, from looking through the code that handles proxying in the Turtl app, I’d guess off the top of my head the proxy does not support TLS and is mangling the data going through it…but that’s just a really quick guess.

Any way you could get me more info on how the proxy is set up?


Hi There, I’m not sure but I think it’s Microsoft proxy server / Microsoft TMG. I had a similar problem with postman but was able to tweak it. Are there any more options for proxy setup or detailed debugging?


Right now there are no advanced options for proxy setup. Do you remember how you fixed it in postman? I wonder if that would give any clues.


Hi Andrew,
Current proxy settings on windows 10:
Automatically Detect Settings = ON
Use setup script = ON
Script address = http://xxx.example.com/wpad.dat
Manual proxy setup is disabled
On postman, i ended up with
Global Proxy Configuration = off
Use System Proxy = off
I also tried the config.yaml file on the turtl app directory but no dice, I changed to a different proxy but it keeps on using the default proxt it detected.