The Turtl program does not run on Ubuntu 19.10


I’m sure it’s an installed through the terminal. I saw at the terminal that the installation was successful. When click an app in the App drawer, the app runs and turns it off.

I don’t know why this is happening although reinstall the Ubuntu 19.10.


I had the same thing with Elementary OS this morning (which is based on Ubuntu 18.04 I think… )

Have had the same issue on Mint as well. I thought it was related to one desktop vs another, but I’ve seen work on Mint Mate with one installation and then not with another. And then work fine with Cinnamon…


Did you by find a solution for this by any chance? I’ve had the same issue on Ubuntu 18 LTS. I’ve tried a number of things but after the install it just tries to open for a few seconds and then stops.

It’s weird, because I just switched back to Ubuntu after using Pop!_OS ( based on Ubuntu) for a couple weeks, where I had Turtl working without issue.


Same problem today because there is not Appimage …

I’ve tried several solutions but nothing works.

Is there an Appimage turtl somewhere to download?