Login failed - "Couldn't connect to server"


Hello everyone,

I have been using turtl for a long time. Although I migrated to the 0.7 version, I am still using the old version/server after the migration. I have been getting the “Couldn’t connect to server” since yesterday, both on my mobile and on my pc. However, I tried re-migrating to the new version and it worked (so the old server must be up). Any thoughts?

Cheers and thank you in advance!


I have the exact same issue. I downloaded the updated Desktop version and then I was able to log in.
However, I lost ALL my previous data.

It seems that the server has moved or something.

I hope the same doesnt happen to you


I also have the same issue. And I saw something that said the security certificate had expired on the url. I have had this problem for a few days and just kept hoping it would get fixed if I waited long enough. Now I’m terrified. I also haven’t upgraded the desktop version, and I was about to do that, but I’m afraid I could lose everything. Does anyone at Turtl monitor this forum?


I have tried using the ‘Feedback’ on the desktop app and made a negative review on Android. I still have not heard back from anyone here.

I just sent an email to them. Let us hope someone is there to respond to our case.


I uninstalled Version 0.7 and downloaded the old turtl-windows-0.6.4
Used my details and was able to enter the old server!

I found all my notes there!

Issue is that I cannot export them out. So going to see if I can share them to myself somehow then back them up and use them in the new server.


Good news! I was still waiting to try the update (primarily out of fear). This morning I winced and I gave my regular sign-in another go. Wow, I’M IN! All my data is there. Using keyboard shortcuts (Windows) you CAN copy/paste all your data elsewhere for a backup. I’m doing so now, and I’ll have to use PGP or some other encryption to secure my backup. That was a scary few days, and it inspires my need to look for an alternative.


Yes, the old server seems to be working again now. Fudfood, there is no way to export the notes from the old version, but you can migrate to v0.7, without losing access to the data on the old version. However, since there are some features that do not transfer (e.g. shared notes), you might need to transfer some of the notes manually. You can read about the account migration process here: