Fail to launch on Debian Stretch


I downloaded turtl, verified the download, and installed the software. Running it from the menu didn’t work, so I tried from the command line, and I got an error:

cd /opt/turtl
./turtl: error while loading shared libraries: cannot open shared object file: No such file or directory

The heck’s going on here? Did turtl fail to install one of its dependencies?

Can't get Turtl running on Ubuntu 18.04

Sounds like Electron, the desktop platform that Turtl uses, is missing gconf2. It’s hard to bundle all the possible dependencies that an app might need with it.

In this case, I’d think you could fix by doing sudo apt install gconf2 on the command line.


Installing gconf2 solved the issue. Thank you.

I strongly urge you to provide Turtl to Linux users either as an appimage or through the package manager. This will make Turtl a lot more popular with Linux users. Personally, I HATE installer scripts on Linux systems. I have to keep a copy of the script around in case I ever want to remove the software cleanly. (YUCK!!)


Agreed! AppImage is on our list of packaging options, and honestly the installer script has been nothing but trouble. The sooner we can get better linux packaging, the better.


I’m using Ubuntu Budgie 18.10.

I was having the same trouble and went through the same steps.

Turtl now opens, but nothing renders - it’s just a white box. My mouse cursor changes as I move around in the white void though, so I guess something is actually there, I just can’t see it.

Any ideas how I could solve/debug this?



Did you get exactly the same error message I did?


If you type ctrl+shift+k and go to the “Console” tab, are there any errors?


@cyborgninjaneer Yeah, I did, exact same error. I installed libgconf-2 and gconf2, which allowed it to open at least, but now I have this blank white issue.

@andrew The console isn’t showing any errors at all, but interestingly, all the HTML elements are there - the form for logging in, etc. Just can’t see any of it!


Same problem as @CalmDownMonkey:

  1. installed turtl on Fedora29 LXDE
  2. installed gconf2 64 bits version (32 bits had been installed at first by dnf, but I don’t know why)
  3. turtl starts on an empty blank screen
  4. tried console as proposed by @andrew but there is no errors, the capture is the same as the previous message

It seems that there is a similar problem on W10: [Windows10] Blank Screen


Im having the same problem on:

Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux

It installs fine but shows a blank white window. No errors in console


Nobody has any idea on how to fix this?


Hi, just install turtl 64 on a 18.04 Ubuntu with Mate and have the same issue…


Just installed Ubuntu 19.04.
Same issue. Turtl installed all right.
When launched, circle spins next to Turtl top left of the screen, than it disappears.
Works fine in Fedora and Centos, but not in Debian 10 nor Ubuntu 19.04


Anyone still having the issue on Debian or Ubuntu, please try installing gconf2. This fixed the issue for me. Turtl depends on it but for some reason doesn’t install it or ask for it.

You can install this library…

If this doesn’t solve your problem, let the developers know because it’s probably a different issue.


I’m having same problem on CentOs8 now. Works great in CentOs7
Tried installing GConf2, but it is already installed.
When launching, cursors spins then it disappears along with Turtl icon.


On CentOs8:
dnf install
dnf install libXScrnSaver



On RedHat8:
dnf install
dnf install libXScrnSaver

Now launching displays a blank white screen


Sorry for the bump, but I did not see a resolution.

I am having this same issue on Linux Mint Tricia XFCE.

Has there been a resolution to this?

Sooooo sorry for the bump. I followed the steps in the thread above, posted this message, then rebooted and turtl worked.

Update #2: looks like I am having the issue where I can only run Turtl once per boot:


$sudo apt install libgconf-2-4

This should fix your launch problem


Thanks for this post. It has gotten turtlapp running on both PopOS! and Kubuntu. Both times I had to DuckDuckGo the same post. Not sure why gconf2 isn’t a default install on either distro yet.