Install turtl on ubuntu


Can somebody say me how to install turtl to ubuntu 20.04?

I can’t.



Are you running into any specific errors or issues during the install process?

I’d be happy to assist, but if you could provide some additional information it would be greatly appreciated.


The install on Ubuntu 20.04 is ok with

sudo ./

but Turtl doesn’t load with this error:

./turtl: error while loading shared libraries: cannot open shared object file: No such file or directory

And, of course,

sudo apt -y install libgconf2-4

doesn’t work on 20.04 :cry:
Any idea, someone?


I go via terminal to the turtl folder.
I make sudo ./
And I get the message: Can’t found the command.

Could anybody help me?


From the terminal when you’re in the folder containing the extracted zip file contents, try running:

chmod a+x

Then run without sudo, and specify a folder for the installed files (e.g. ~/Apps/Turtl)

./ ~/folder_you_want_installation_files_to_live

Hopefully that helps, but let me know if you get any new errors or run into any issues.


now I’ve this error:

Copying Turtl to install directory (/opt/turtl)…
cp: no es pot sobreescriure el directori ‘/opt/turtl/./turtl’ amb un no‐directori
Error copying Turtl

On the second line it says » Can’t overwrite the folder ‘/opt/turtl/./turtl’ with a no-folder

I’m not used to use terminal and I don’t know how to solve it.


what was the exact command you ran in your terminal to produce that error?


sudo ./


Sorry for the slow reply.

Try the following:

mkdir ~/Apps
sudo apt install libgconf-2-4

Then from the the directory you have the install script:

chmod a+x
./ ~/Apps/turtl

I setup a virtual machine with Ubuntu 20.04 and to test this and verified that it was working.

Hopefully, this helps.



Thanks for your enormous patience.
Finally I could install turtl on ubuntu!!!


I was running into the same issue regarding libgconf-2-4 on Debian 10.

After I did, sudo apt install libgconf-2-4 it installed successfully. :smiley:


je tente en vain d’installer turtl sur ubuntu 20.04, en particulier avec ces commandes dans le terminal et depuis le répertoire où se trouve. avec “chmod…” la réponse est “…ne trouve pas ce fichier”
quelqu’un peut-il m’éclairer ? existe-t-il une procédure type d’installation ?


hi all,

I am having issues installing Turtl on Linux Mint 20.1 (x64 - based on Ubuntu 20.4)

I’ve downloaded and unpacked 0.7.25 .bz2 and proceeded with the install using:

sudo ./

(also tried with chmod a+x afterwards, no cigar unfortunately)

it seems to install, I can also find turtl in /opt/turtl/ but running it from terminal shows

_/opt/turtl/turtl: error while loading shared libraries: /opt/turtl/ cannot read file data: Error 21_

looked around and tried

sudo apt install libgconf-2-4

which does install, no issue, but still creates the same error.

Tried uninstall and reinstall again. Nothing so far.

Any ideas?